Student Authentication Support

    Technical Requirements for Users

    Follow

    BioSig-ID works with all the Learning Management Systems being used by NMLS approved course providers. The following lists the currently supported system requirements for end-users.

    If you do not have the basic requirements on the system you are trying to use, you will not be able to create a profile.

    Supported Operating Systems:

    Any OS that can run a W3C HTML5 compliant browser

    • Microsoft Windows XP, Vista, 7, 8, 8.1, 10
    • Mac OS X 10.6.x, current release 10.12.6

    Supported Browsers:

    Any W3C HTML5 compliant browser**

    • Microsoft Internet Explorer 8+, current release 11.1480.14393.0
    • Mozilla Firefox 3+, current release 55.0
    • Google Chrome 4+, current release 60.0.3112.90
    • Apple Safari 6+, current release 10.1.2
    • Opera 9+, current release 47.0.2631.39

     * We use HTML5 current release, No Adobe Flash

    Supported Input Methods:

    Any input method that allows the user to draw and select

    • Mouse
    • Stylus
    • Touchpad
    • Touchscreen

     

    Was this article helpful?
    2 out of 5 found this helpful

    Comments